← Tutti gli errori

SQLCODE -603

SQL0603 Indice unico impossibile per chiavi duplicate

Testo del messaggio IBM
Unique index cannot be created because of duplicate keys.
SQLCODE
-603
SQLSTATE
23515

La causa più comune

CREATE UNIQUE INDEX, o un vincolo UNIQUE, su una tabella che contiene già valori duplicati per quella chiave.

Altre cause

  • Duplicati fatti di NULL: si può usare UNIQUE WHERE NOT NULL.

Come si risolve

Trova i duplicati con GROUP BY chiave HAVING COUNT(*) > 1, correggili e ricrea l'indice. Il joblog dice quali righe sono duplicate.

Errori collegati

Testo e codici dalla documentazione IBM di 7.6. Controllato il .