← Tutti gli errori

SQLCODE -904

SQL0904 Limite di risorse superato

Testo del messaggio IBM
Resource limit exceeded.
SQLCODE
-904
SQLSTATE
57011

La causa più comune

Un limite superato: il messaggio dice quale con un tipo. I più frequenti: lo spazio massimo del profilo utente (tipo 1), il limite di risorse di una query (tipo 3), la dimensione massima della tabella (tipo 6).

Altre cause

  • Troppi lock di commit (tipo 5) in una transazione molto lunga.
  • Troppi cursori aperti nel job (tipo 8).

Come si risolve

Leggi il tipo nel messaggio e i messaggi precedenti nel joblog. Per il tipo 1 aumenta il limite del profilo o libera spazio; per il 5 fai COMMIT più spesso; per l'8 chiudi i cursori.

Testo e codici dalla documentazione IBM di 7.6. Controllato il .